先升级 npm 可能会导致 nodejs 和 npm 版本不一致,无法安装其他包

npm 安装包失败可尝试以下命令:

1
2
sudo chown -R $USER:$GROUP ~/.npm
sudo chown -R $USER:$GROUP ~/.config


1
sudo npm install -g --unsafe-perm=true --allow-root

安装 node-sass 失败

1
sudo npm install node-sass@4.11.0 --unsafe-perm=true --allow-root